Freezes when stitching auto pano or trying to cancel stitching in process (ios) v2.14.3

I’m struggling to get high-quality panos to stitch, stays stuck at around 80% for hours
If I try to cancel a stuck stitch then app shows “canceling…”. I left it running overnight and was still stuck in the morning

Possible reasons:
-It takes some time to download all the relevant pictures from the drone to your device, perhaps you turned off the drone too early.

-Your apple device can’t handle the amount of pictures by either/or/and:
–not enough storage left
–not enough ram
–processor not powerfull enough


The first step in creating a high-quality pano is to download the photos from the drone to your iDevice. The whole process should take minutes, not hours. You obviously powered off your drone before the stitching process was complete. I’ve never tried that. Are you sure that all of the photos were downloaded to your iDevice before powering off the drone? Have you tried the entire process while your drone was still powered on? I’ve done this many times using an iPad and it has worked. Exactly what device are you using?