Found solution for RCpro air2s intermittent disconnecting

I’m a 1 day old user of Litchi.
Using the RC pro with air2s.
I have this red disconnect and opti sign that keeps switching. And the battery status will flicker.

I find that besides going to setting to stop the launch of the DJI fly app, the DJI fly app location service is still running in background.
When I disable the location service of dji app, the DJI app will be hidden and then immediately my aircraft is connected and the battery status does not flicker anymore.
However, when you switch on the rc pro controller again, the dji app will appear at the desktop and u will need to go and disable the location service again.

I googled and found that we should set the frequency from auto to 5.8 for better transmission too?

First thing is go into RC Pro settings and stop the DJI Fly app from automatically starting. That will stop having to go into settings everytime to force stop the Fly app before starting Litchi. I leave the frequency selection to auto on mine