Flying Air2S or Mavic Mini, the drone starts hovering on waypoint 2 or 3 and doesn't fly the rest of the mission

I have been trying to fly a mission using both DJI Air2S and Mavic Mini using the Litchi App. I created a waypoints mission, upon flying them the drone goes from the homepoint to the first waypoint and then the second after which it starts hovering over the second waypoint, without completing the mission. I have tried various settings where I turn the Auto Record off and toggle the AFC setting. Nothing has seemed to work for me. I made sure I have the latest firmware updated too.

Whereas, my colleague seems to be able to fly both the drones with the no problem on her phone. She has Iphone 8 and I have Iphone 13 pro.

This is caused by degradation of the control signal.
Study this thread, and be sure to watch the embedded video.

1 Like

Thank you for your reply, I appreciate you taking the time to help me. I don’t think this is the issue since there is no obstacle between the RC and the drone and this happens no matter where I plan the mission. For the same waypoints mission with the RC being in the same place, my colleague is able to fly the mission using her phone as the RC.

Only the mavic pro, spark and mavic air can be controlled by a smart device as RC.

Wifi & bluetooth can be of influence to the control signal of the RC, turn both off on your phone.

Air2S does support the smart controller and that is how I’m flying the waypoints mission using my phone. I turned off the Wifi and bluetooth but the problem still persists.

The smart controller has a build-in screen and can’t be used with a phone.
Also it operates only on occusync 2, the Air2s, RC-N1 (RC231) & DJI RC (RM330) have occusync 3.
This means when you use the Air2s with the smart controller it switches to occusync 2.

This implicates that a phone is used to control the drone without the use of a remote controller (RC), only the 3 above mentioned drones are able to do that.

You have to be more precise/accurate in describing the equipment you use.

Which type of phone is used does not influence the control signal quality of the remote controller, only the environment and broadcasting system (WiFi, lightbridge, occusync) AND the position of the antennas relative to the drone (consult your drone’s user manual).


I am sorry about the confusion since I didn’t use the proper terminology. Thank you for enlightening me on it. I use the DJI RC-N1 which I believe enables the use of phone to be connected via a wire. So it must be Occusync 3. If you think the control signal quality could be the issue in my case and not the phone, my question to you is how come does the same mission plan, flown on a particular drone using a phone with the Litchi app works fine while standing from a particular spot but when flow using another phone on that particular drone doesn’t. Please let me know if I need to give any more information.

The environment and/or position of the RC-N1 relative to the drone.

-Time of day (interference from WiFi/microwave networks), obstacles (foilage, structures), weather (temperature, humidity, static charge), solar radiation…

I have uploaded my mission here, I have also pointed out the RC position as in the position from where I hold the DJI RC-N1. The altitude of the mission is 160 ft. So this particular mission was flown using 2 phones one after the other connected to the RC. The first phone when it was flown had no problem at all. When I flew the mission few seconds after the first flight with the second phone with me standing in the same location as the first flight, the drone tends to stop at waypoint 3. No matter what time of the day I fly the flight with the first phone goes about well but the second phone always stops at waypoint 3.

I fly an Air 2s with an RC-N1 and an iPhone 13 Pro. I have excellent signal strength. You should be able to easily fly that mission. Do you see the signal strength decrease as the drone approaches waypoint 3? There must be some serious interference in that area. If you use AirData, I would check the signal strength map for that flight. If you don’t use AirData, you should. Using a different iPhone shouldn’t make a difference. I can’t explain why it does for you.

@Manmohan_Veerappan, it sounds like your phone is the issue here, but try a 3rd phone or tablet just to verify that other devices work with no problems.

Thank you for your suggestion, I downloaded Airdata and the signal strength seems to be good throughout the mission but it still hovers over waypoint 3 without proceeding further. Airdata seems to be a very useful app, thank you for the recommendation.

1 Like

Thank you for your reply, I don’t have a third phone to check this out.

Any chance you could check your missions using another friend or colleague’s phone? If so, make sure that your settings are the same with all phones or tablets that you are using to compare the missions. I hope you can fix the issue, good luck!

Do you also have the DJI Fly app on your phone? Are you force-closing it when you fly using Litchi?

1 Like

Yes, I do close the DJI Fly app before every flight.

Does your colleague also have the Fly App on her phone or does it only have the Litchi app? Sometimes the Fly App can cause problems even when it is supposedly closed. Some Litchi users either remove the Fly App after updates or have a second phone with only Litchi on it. Unless there is some serious problem with your phone, checking your Settings and making sure Apps don’t interfere with each other is the best path to fixing your problem. Again try to find a 3rd device for comparison to find out why your friend’s phone works with Litchi and yours doesn’t.

Thank you for your advise, I deleted the app but it still doesn’t make any difference. My colleague has the DJI Fly app on her phone. I might try to do it on a third phone.

1 Like

An important thing to consider when comparing either 2 or 3 different devices to your own is that the settings are consistent on each device. Look for anything in the phone/tablet settings that may be different, this includes the phone as well as the apps. Deleting and reinstalling Litchi and the Fly app sometimes helps, but make sure that you approve all permissions requested. If you had no problems using Litchi prior to this, then it would seem to be either a bug in the setup or as Yordie mentioned, there must be some kind of problem with your reception and may be a location based problem like interference.

1 Like