First Time user, Video feed is not working

Hi Team, i’ve just downloaded the app and tried it with my Mini SE Drone. With the DJI Fly app the video feed form the drone is perfect. But with this Litchi app it seems to show a still image form the camera for 1 second, then goes blank, then 30 seconds later it will do the same. it’s like it is trying but can’t stream the video. i am using a Pixel 6 phone with Android 12 and it is connected via the USB to the controller.

So far i have tried changing all camera settings in the app, no luck, i have perfect signal for the receiver and the drone flies perfectly too, and also shows an accurate location on the map screen, just no video. When i installed the app i allowed absolutely every permission it asked me.

Any idea’s what i can try. i’d love to get this app working as just paid for it and has so many good features.


Known Issues in Litchi 4.21.2 on Android:

  • Live video feed does not work on Google Pixel 6 series: we will update as soon as DJI fixes it in the SDK
  1. You could first try a different usb cable from the controller to the phone.
  2. Try a different sdxc card in the drone / make sure that it is formatted in the drone.
  3. uninstall and re install litchi app.
    ( It is silly little things like these that cause the most troubles )