Failed to execute mission

This has happened to me before and I resolved it before, but…, I never really understood how I managed to resolve it. This is a mission I fly once per month and the flight plan never changes but this morning it took off, climbed to about 50ft and refused to execute the mission informing me that there was a change.
The only difference this morning was that I launched from a location roughly about 30 to 40 feet away from where I normally launch. So after 3 attempts to launch from this new location which, like I stated was roughly 30/40 ft away I moved back to where I usually launch and it turns out that appears to be the reason for the flight change and refusal to launch.

Is this normal behaviour? The launch location is not the first waypoint. That’s actually about 120ft away and at a height of 150ft.

Was there any kind of an error message?

No, that is not normal behavior. You should be able to launch from other locations. Depending on the other locations, there might be some differences in mission height but the mission should start.

There is nothing in your description that should prevent the mission from starting so there must be something that you are not thinking of or not mentioning.

When you say “refused to execute the mission”, exactly what does that mean? An error message? Screen unresponsive? Something else?

I load the saved mission. Press the play button, ensure that waypoint 1 is the first waypoint highlighted and press GO. It takes off to a height of 25ft and stops. The audio responds repeating the height details and current speed, In the Top right corner the message “Mission Interrupted. The flight mode was changed” appears. After 3 attempts I moved back to where I normally launch from and it worked.

Is is possible that you had tried to take off from within an “Authorization Zone”?

1 Like

Nope! No such zone in this location. I have a screen recording which I can upload and I just noticed as well at 1 min 17 secs it also tells me Go home command failed. Again I’m assuming it’s because I’ve not launched from my normal location as it did return to the new launch location.
As we all know viewing a phone screen in bright conditions can be quite challenging so I’m wondering if it’s possible for the programmers to also add these generated errors to the litchi audio prompts.

I’m uploading the video to you tube.
Litchi Mission Error

At 0:50 into your video I can see that the flight mode goes from “P-GPS” to “APAS”. This is what is triggering the “Flight Mode Changed” error. The drone must be sensing some sort of obstacle near your take-off location. Either move away from that obstacle or disable APAS in the Litchi settings.

APAS = Advanced Pilot Assistance System, which is its obstacle avoidance technology


Know your drone…read the manual.

Your drone went into APAS mode due to detected obstacles nearby.
Disable APAS (page 25).

RTH was ignored by the drone because its distance from the home point was too small, instead landing was initiated (page 13).


Thanks for that. “Every Day’s a school day”

I never noticed that. Like I said it’s hard on most days to read the screen so it would be helpful if the app could advise via audio prompts of the errors as they occur. One of the things I really like about the Litchi app is the audio feedback. It allows me to concentrate more on where the drone is visually rather than trying to view the screen

1 Like