Error uploading waypoint program due to gimble error

I created a waypoint program that loads fine but when I attempt to run it I receive an error that it is unable to be uploaded because of a gimble error of some sort. Gimble is set to disabled for the program settings and each waypoint because I want to control it manually.

The error message is chopped off as displayed so I can’t see the entire error message. I’ve checked similar programs and don’t see any differences. How can I get more detailed info about the error, I can’t click on the error message to expand it? Is there a log file?

Would you be willing to share your mission so that we can take a look? If so, uncheck the “Private” checkbox in the “Open” dialog then paste the URL in a reply to this message. Without seeing how your mission is configured, all you will get will be guesses (unless this has already happened to someone else).

1 Like

New to this and see you cannot make something public in the Android app, only on the website.

But here it is: Mission Hub - Litchi


That is correct. The Mission Hub is the primary mission design interface and is the only place where you can make missions public (or private).

Having looked at your mission, I have several suggestions for you to consider:

  1. You have some camera actions configured at waypoints 2 and 9. The Litchi manual states that: “Important: Waypoint actions are ignored when the mission “Path Mode” is “Curved Turns” as the aircraft will not stop at waypoints them.” Therefore, you should delete those camera actions as they will not be executed.
  2. At each waypoint, set your “Gimbal Pitch” to “Interpolate” and your pitch angle to -90. This will match what you had set in the waypoint 2 camera actions. Of course, you can set your pitch angle to any value you desire (generally between -90 and 20). If you really want to control it manually, leave this setting to “Disabled”.
  3. In “Settings”, your “Path Mode” is set to “Auto (TNW)”. There is nothing wrong with that. It will cause the heading of your drone to always be tangent to the flight path. That is fine if that is what you want. The more general and often used setting is “Custom (WD)”. The custom mode allows you to specify any heading you wish at any waypoint, giving you a bit more flexibility.
  4. I noticed that your “Finish Action” is set to “None”. I would strongly encourage you to change that back to the default of “RTH”. I have seen too many cases where a user had set that to “None” and then for various reasons (such as a lost connection) either had their drone hover until the drone went into forced landing mode at a location which made it difficult or impossible for them to retrieve their drone. RTH is by far the safest setting for the “Finish Action” unless you have a specific reason for changing it.

Try making these changes and give your mission another try. Please let us know if you have success.


Thanks Wes! I’ll give these suggestions a try when the weather clears up. I will have to read up more on what settings are not compatible with others and that sometimes “ignored” does not really mean that, assuming the camera settings are what fouled me up.