Error 148 contact DJI

I am using a M2EA thermal drone for solar panel inspection, I set up a mission and tried to have litchi fly it, but an error stating “cannot take off error 148 contact DJI support” that actually made me laugh.
I was flying in restricted airspace with authorizations both LAANC and DJI flysafe.
I’m using the Smart Controller.
Litchi loads, I’m force quitting the Pilot app and the error message appears.
I tried leaving the Pilot app running after turning on the flysafe authorization but it had no effect.
Anyone have this issue and did you find a solution?

All firmware up to date?

Yes the newest version with Remote ID

Perhaps my routine flying Litchi missions in DJI Flysafe zones will help:

  1. Start the controller with only DJI Fly app then start the drone and UNLOCK the DJI Flysafe license.
  2. Shut down the drone and close the DJI Fly app and turn off your controller. The unlocked DJI geo zone should now be stored on your drone.
  3. Restart the controller with the Litchi app and start your drone. Litchi should should recognize the unlocked DJI geo zone on your drone.

I hope that helps.

I will try but the enterprise drones use the pilot app, I will look for the fly app but I don’t think it’s available.
Thanks for your help.

That is correct. The M2EA requires the Pilot app, not the Fly app.

Since the unlocking token is stored in the drone, you can troubleshoot this by seeing if you can fly using the Pilot app. If that works, then close the Pilot app and run the Litchi app. Instead of trying to immediately fly the mission, just check to see if you can manually take off without errors. If that works, you have at least eliminated the unlock request and token causing the problem.