DJI Spark Stops During Way Point Flight

Ok, so I’ve been flying my Spark and Mavic Air (Gen I) for years now. I have litchi waypoint missions that I frequently run between the 2 of them. I’ve noticed that over the last few months, my Spark will start the missions, and then suddenly stop part way though. If I fly my Mavic Air through the same missions, it will run straight through to the end. Any ideas as to why my Spark is hanging up?

What version of Litchi are you using (please don’t say “the latest”, that doen’t mean anything)?

Does this occur with the exact same mission flown with the Mavic Air & Spark?

Are you getting any message when the Sark stops?

Does the Spark stop at a specific waypoint or in between 2 waypoints and at the exact same position every time?

I found that a thorough and comprehensive calibration of everything that requires periodic calibration was the cure that worked whenever I noticed my Mavic 1 Pro and Mavic Pro Platinum stopping uncommanded during Litchi waypoint missions.

I don’t own a DJI Spark so I am not sure if it has collision avoidance sensors but if it does, they MUST be calibrated even if they are disabled during waypoint missions to maximize airspeed. So in summary, calibrate the IMU, the compass, all collision sensors, and the camera gimbal. This full calibration worked every time for me, and resulted in a much smoother flying drone that no longer stopped unexpectedly during waypoint missions.