Disconnecting from app after launch

I have been using Litchi to fly preprogramed pathways for video and photo with no issues a few times. two out the last three times, the app with disconnect after I have launched the drone. I am new to this space and I am just not sure why it all sets up correctly then disconnects while in the air.
I am using a DJI Mavic Pro 1.
I have previously opened the DJI Go4 app to calibrate the drone when out on site, closed everything and shut down. Then turned it all back on and connecting to Litchi. This has worked in the past.
It is a building construction site, so I thought maybe the steelwork framing could be interfering? It is only a two story building.
If you have any suggestions please let me know.

I had a similar issue today. First attempt the drone stayed at one corner of the construction site and would not progress to the next way point so I had to abort and RTH, Created a new flight plan and it completed but not without problems as can be seen in the Flight Logs. However I’d need some help in deciphering the flight logs so if anyone can help let me know and I’ll upload the logs.

Its interesting because I had this issue one flight, then it worked. Then the next trip flew with no issues whatsoever. Then the last one disconnected everytime. My site is quite remote so I would like to sort this out before I drive out there and face the same issues.

Have you flown again?

I am hesitant to recreate a flight path for fear of not getting the points the same and ruining my attempts at a construction timelapse!

Two possible causes:

  1. You did not FORCE CLOSE the DJO GO4 app before starting Litchi.
  2. USB related:
    -Faulty USB cable
    -Loose USB connector(s)

Force Close an app on android:
-Tap the 3 vertical lines (button) in the lower left of the screen.
-Smaller screens/icons of all open apps wil be shown on the screen.
-Tap ‘Close all’.

For what it’s worth:
Once your Mavic Pro started a mission (your screen says: ‘uploading mission 100%’), it wil fly and complete the mission even if you shut down the RC.

1 Like

Your problem is not even remotely similar.
Your Air 2S is a so called VSC drone, and this is typical behaviour for VSC drones when the connection between the AC and RC is intermittend.
So is the ‘Jerky Video’ in one of your posts.
Did you actually read the topic about VSC drones @Steve_Amerson pointed you to?
Here is the link again: