Deleted Missions keep re-appearing! SOLVED?

Greetings All,

I have made many updates to existing missions and deleted the originals both in “Mission Hub” AND on the App. SOMETHING keeps restoring them.

I’m getting a huge list of Missions I can’t seem to delete. I delete them, and they are back the next day.

I could use some “Adult Supervision”. Any suggestions?


It may sound silly but I want to confirm how you are deleting those missions. Are you selecting “Open” from the Mission Hub menu and then clicking on the trash can icon next to the mission you want to delete?

Deleting them as you describe, then also deleting them from the Android app on the Smart controller.

I have another copy of the app on my IOS device which does not allow deletion. I removed the app from the iPhone and we’ll see in the morning if it eliminated the problem. I can’t think of anywhere else those missions could be syncing from.

I’m not real thrilled about not having a “Back-up” way to fly should the Smart Controller run out of battery. I can always re-install if necessary.


To delete on IOS you would swipe left on the mission name to delete.

Sorry, at the moment I cannot think of a reason for you to be experiencing this problem.

To delete on IOS you would swipe left on the mission name to delete.

Did Not know that…

Is there a limit to the number of Missions that can be in the System at one time?

Some method of Folders or categories for Clients would really help organize.


There is no practical limit on the number of missions. I have never reached it and to the best of my knowledge, no one else has and posted about it.

The only reason I mentioned it is because I keep getting that “Too many missions” error message when saving updates.

Hmmm. I’ve never seen that error. How many missions do you have?

The only mission-saving error I occasionally see is:

This happens when you save one mission and then try to save another one right away. I’m not sure why that would be a problem but Litchi prevents you from saving new missions too often.

OK, That explains that… I sometimes makes small tweaks and save rapidly.

Good news. The Missions did NOT re-appear this morning. It must have been syncing with the iOS copy.
Now that you showed me how to delete in iOS, I may put it back on the iPhone and see if the problem returns. Or maybe I’ll just let sleeping dogs lie…

I generally only have a Couple dozen Missions at a time. Multiple Still and Video for the same projects for mapping and to document Progression. The list is difficult to scroll with my fat fingers and easy to load the wrong Mission. On the “Smart Controller” the type is about 8 points or smaller in the “List”

So, Problem solved, Thanks for your help.

I use IOS (an iPad Mini 5) and haven’t experienced any deleted missions reappearing. Give it a try again.