CrystalSky and Waypoints

Hi, have been using Litchi on a CrystalSky monitor for about 10 months now, but have a problem changing modes. The app starts in FPV mode and I immediately switch to Waypoints. However the app stays in FPV mode and checking the menu selction again, it’s almost partly showing Waypoints ( button partlt highlighted ). All I can do is just wait and the app will suddenly ‘catch up’; this can take several minutes. Have I missed something?? Updated to v4.24.1-a yesterday, but still see the same problem. Have also tried with and without the controller connected and both situations behave the same. TIA!

Try clearing Cache and/or Data in ‘Settings → App Info’.

Thanks for the reply. Tried clearing the cache, but it made no difference. Have yet to try clearing all data, as the last couple of weeks have been hectic with tasks.
However, it appears to be connectivity related! I almost always have the hotspot on at the point I fire up litchi… but if I turn the hotspot OFF first, it drops straight into waypoint mode when selected. With the hotspot ON, is it trying to drill home first or check litchi accounts??