Control of front leds not working on P3 Advanced

Hi i was flying my ptantom 3 advanced yesterday and had front leds set to my c2 button but they wouldn’t turn off. I messed around with it and found the radio button for front leds in the settings and that would turn them off either. Any ideas why i don’t have this function?
I tried restarting my iPad mini, closing and only opening the litchi app and starting the drone and app according to litchi directions.

Try to find out if your C2 button isn’t broken by linking other functions to it.

…and if you can’t control the gimbal with the left wheel, there’s definitely something wrong with your controller.

So i reset the controller and that fixed the gimbal issue but not the led issue. Odd…
The c buttons work with other features but not the front led…

How did you reset the controller ?

I don’t have a Phantom 3 Advanced, but I do have a Phantom 3 Standard. So I fired it up and just tested the “Front LED” option in Litchi’s Settings. It did not work for me either. The LEDs stay on. Did this ever work for you on the P3A? My guess is that this function does not work on the Phantoms.

That’s a good question, i thought it did but i can’t remember what i had for breakfast so I’m not sure.

Thank you for checking

1 Like

I googled how to reset it, then followed to steps. I’ll try and find the link again.

How to hard reset Phantom3 Advanced controller? | DJI FORUM.