Can Litchi be used to bind a Mavic Pro to its controller?

I purchased a used Mavic Pro 1 from eBay recently and flew a number of Litch waypoint missions without encountering any problems. A couple of days ago I attempted to launch the Mavic Pro but found that the controller was no longer bound, or linked to the drone, despite there having been no crashes or even hard landings to explain such a major anomaly.

In addition to Litchi’s superb waypoint planning capabilities, I also use Litchi exclusively, and NEVER use DJI Go or DJI Go4, because I have absolutely zero interest in downloading any DJI upgrades, given that the drone flies perfectly without such upgrades, and bearing in mind the numerous complaints I have read online from DJI drone owners who encountered major problems after allowing “upgrades” into their drone and controller firmware.

I wrote to the DJI forum about the disconnected linkage between my Mavic Pro and its controller, and their reply was that I carry out all updates and then test the drone again. Now, as I mentioned earlier, I’d rather have my teeth pulled with a pair of rusty pliers than accept an unsolicited update of dubious benefit to me, so I am now seeking a means by which I can restore the connectivity between my Mavic Pro1 and its controller WITHOUT updating anything.

Over a lifetime, I’ve learned to regard with extreme scepticism and deep suspicion any advice that I forcibly comply with some issued instruction simply because it is “for my own good”, and this is why I am desperate to avoid downloading any DJI update that promises “better performance” than the current capabilities of my drone which happen to satisfy me 100%. In short, I am a rabid believer in that old maxim that advises “If it ain’t broke, then don’t fix it”.

After numerous tries to re-link my Mavic Pro to its controller failed using DGI Go4, and then reading that the only advice offered by DJI to address this disabled drone syndrome was that I obey the command to “update” my drone and controller whether I wish to do so or not, I thought I’d better check with Litchi to see if I could side-step DJI’s forcible update command now and forever.

If anyone is aware of a menu item in Litch that enables DJI owners to re-link their drones to the controllers without being forced into carrying out any updates, I would be eternally grateful. Right now my DJI Mavic Pro 1 is dead in the water, even after multiple attempts to re-link it to its controller using the DJI Go 4 platform.

Sequentially press the buttons C1 - C2 - Rec - Shot. = two customizable buttons at the bottom of the remote + video recording + photo shutter. After such successive presses, the remote control will start beeping. And, if at this moment the copter is in the bind mode, the remote controller will bind to the copter.

1 Like

To put the Mavic Pro into remote control binding mode, you need to press a button with a sharp object under the cover on the right side of the drone where the flash drive slot is still located. After pressing the button and activating the remote control binding mode, the light next to this button will turn red. After the aircraft establishes a connection with the remote control, the light will turn green.

This reply is appreciated Paxxa. I tried the C1/C2/Rec button press and hold followed by the shutter tap after the intermittent beeping started, and ending with the pressing of that small button beside the wifi/RC switch until the red light illuminated, on multiple occasions yesterday, but thus far without success.

The Mavic Pro manual’s use of the word “toggle” in reference to that wifi/RC switch is baffling and ambiguous. One possible interpretation of the word “toggle” as used in this context is that the switch remains in the wifi position for normal drone flying operations, but then is briefly switched over to the RC position only for the binding procedure, before being returned to the wifi position.

A second alternate interpretation of the word “toggle” as used in the manual is that the switch is to be shifted over from the wifi position to the RC position during the binding process and then left in the RC position thereafter for regular flights. I frankly have no idea which interpretation of the word “toggle” is the correct one, since trying both ideas has failed thus far.

Finally, in despair, I very reluctantly went ahead and updated the drone firmware and controller firmware for both the Mavic Pro and Mavic Pro Platinum, via the DJI Assistant 2 platform on my desktop, but even after those updates, I have made no headway in my quest to re-link either of the two drones with their respective controllers.

I have limited patience when it comes to repeating the same identical procedures over and over again with the same failing results, so I’ll try a few more times today and then perhaps retire both Mavic Pros for the time being, in order to resume flying my old Phantom 3 Standard which has never given me any problems over thousands of Litchi waypoint miles flown out here in the sticks. In retrospect, I might have been better off never purchasing these Mavic Pros, but then hindsight is 20-20 haha.

You need to keep the drone and the remote control at a distance of 20 centimeters

1 Like

I am grateful for this reminder, Paxxa, and will place the controller much closer to the drone on my next attempt. Now there is one possible source of interference that I must mention, which is that on the very rear of the fuselage, just above the orange status light, I installed a small PC board strobe light made by Firehouse, whose bright flashes are visible a mile away in daylight.

That rear-facing location for the strobe lights was the result of not being able to come up with a better location for that strobe on the drone, and those strobes are really effective in causing raptors to break off their attack swoops toward the drone, as my video footage has shown often.

The position of these strobe lights has not proved detrimental over many hours of normal Litchi waypoint flights in the past, yet it did just now occur to me that perhaps if the strobe modules are in that position during the binding process, failures are more likely to occur due to interference.

These strobes are glued on with adhesive so I’m reluctant to remove them for a logical test to determine whether the RC binding process might be hindered by the strobe’s presence because the adhesive surface holding those small PC boards in place is likely to lose gripping strength if re-affixed after being detached. A strobe I once owned now sleeps with the fishes of a tropical swamp due to velcro mounting separation at 250 feet of altitude.

Apologies for these minor digressions from all things Litchi, but since I only ever fly fully autonomous Litchi missions planned on The Hub with average distances of 6 miles round trip per flight well beyond RC signal range with 2,300 miles covered and counting, my Mavic Pro woes are at least tangentially relevant to the theme of this discussion forum.

I’ll report back as my comedy of errors unfolds here, and any pointers that can be offered by Paxxa and other drone scientists would be gratefully implemented here in the hopes of getting my Mavic Pro drones into these skies again soon.

Finally got the Mavic Pro working normally, and the problem was so simple I’m slightly embarrassed to own up. The SD card was one of the older 32GB ones I had laying around. Swapped it out for a faster and newer 64GB SanDisc SD card, and the drone resumed normal operation instantly.

Thinking I might be on a roll, I swapped out the SD card in the Mavic Pro Platinum with that newer 64GB SD card, but that solution didn’t work as it did with the Mavic Pro. Anyway, I’ll keep plugging at it, and will duly report the resolution that ultimately solves this connectivity issue, even if it turns out to be something trivial that ought to have been obvious right from the get-go.

I will now add a MAJOR word of caution to any Mavic Pro or Mavic Pro Platinum owner that ever should find themselves locked out of their drone as I have just been, and urged to update the firmware as a prerequisite to once again flying that drone.

The most recent firmware update offered for the above-specified drones, and possibly even for ALL DJI drones going forward, is designed to DISABLE that drone PERMANENTLY from Litchi, and thereby FORCE users to operate their drones with DJI Go products ONLY, going forward.

I am writing these words in my official capacity as the Litchi community’s self-appointed guinea pig, with all privileges and rights implied. The Firmware version updated to Version V01.04.0050 which is the latest edition dated 2018-09-03, is specifically designed to terminate with extreme prejudice the use of DJI products by ALL drone owners who happen to prefer Litchi’s formidable waypoint capabilities and therefore use Litchi EXCLUSIVELY.

If like me your primary or even sole use of DJI products entails flying waypoint missions with the Litchi platform to the complete exclusion of all other offerings, let me spare you a whole lot of grief by urging that you do NOT update your DJI Mavic Pro or Pro Platinum drone’s firmware to Version V01.04.0050, whose PRIMARY function is to deprive you of access to Litchi’s amazing features for the rest of all time.

If my intended countermeasures do not succeed, then I will wind up with a pair of very costly conversation pieces that I will have no choice but to sell off in favor of buying an Evo product in the very near future. To describe my current mood as one of utter disbelief and righteous outrage would be an understatement. Litch users don’t fall into DJI’s horrible update trap as I have done. Yee hath been warned, so tread with great care. I wish I knew 72 hours ago what I know now.

You can flash old firmware with DUMLdore

This hint is gold, Paxxa. I first tried DJI’s own rollback feature, but it evidently will not do anything of the sort. Still stuck on 1% of the purported “rollback” firmware download after swapping in a second fully charged battery when the first attempt failed midstream so the official path looks like a red herring dead-end that is intended as such.

Next, I went to No-Limit Drones, where I was certain I’d seen a tool specific to the Mavic Pro series, yet cannot find it now. Feels like a Twilight Zone episode here, as I flail about in panic over my drone’s sudden incarceration by a dastardly and cunning nemesis.

Trying DUMLdore next.

Couldn’t see the trees for the forest. Stumbled on No Limit Drones finally.

I know only free resources where you can find all the information ;). I can’t tell you about the paid ones :slight_smile:

1 Like

I nearly forgot that there might be an Omerta code of silence that needs to be observed now and then in these delicate matters hehe. Suffice to say the Mavic Pro1’s solid reputation as being ahem, “amenable and forgiving” does help to douse my earlier worries that the end of the world was nigh.

The Pro 1 lets you do just about anything and is therefore a very good drone these days.

1 Like

Why would DJI bother to create and distribute their SDK for software companies like Litchi, Dronelink, and Maven only to disable them from using the SDK? Your suggestion doesn’t make sense.

Perhaps the previously symbiotic relationship between DJI and Litchi has soured in recent years, as increasing numbers of previously loyal DJIGo users migrate over to Litchi due to the increasing number of restrictions imposed by DJI on drone capabilities and airspace access.

Speculation aside, what I can state with absolute certainty is that in the aftermath of DJI’s most recent firmware update on my Mavic Pro, the drone is only able to function via DJI Go4 with a normal camera image visible, while the Litchi screen and camera view are very obviously disabled and inoperable. My attempts to bypass DJI’s anti-rollback protocol have thus far proved to be an extraordinarily difficult, complex, and time-consuming endeavor.

I will update here again later as I explore one countermeasure after another in a bid to reconnect at least one of my two Mavic Pros with Litchi since I have no intention whatsoever of flying any drone within DJI Go’s incrementally restrictive protocol.

DJI released the SDK for the Air 2S just this spring. I haven’t seen and sign of “souring”. Why would DJI care whether someone used Litchi, Dronelink, Maven, or Go or Fly to fly their drones. It’s not like DJI is loosing any money because someone bought Litchi. If anything, DJI is making more money because someone can use Litchi.

Any no-fly zones or unlocking licenses are loaded into the drone. It doesn’t matter whether you use Litchi or not. Unlocking must be done using DJI software.

Wes, I sincerely hope your presumption is right, that DJI harbors no underhanded agenda against Litchi. A mere 72 hours ago, any notion that Litchi could wind up blacklisted by DJI would have made no sense to me, yet now I can think of no other logical reason to explain the selective disabling of Litchi as a direct consequence of my having reluctantly installed DJI Go’s latest firmware update after my drone suddenly and inexplicably lost its controller link hours after an uneventful flight.

In a desperate bid to retain Litchi connectivity to my Mavic Pro and Pro Platinum drones, I’ve now ventured into the bewildering morass of after-market hacking platforms, two of which have finally enabled me to roll back the firmware editions on both the drones, but NOT on their controllers, meaning of course that neither drone can be linked to its controller for flight until that little puzzle is resolved.

Evidently, drone hack website operators aren’t disposed to discussing customer complaints, so I’ll flail about in the fog trying to find the answers to my questions by trial and error.

I happen to reside in a remote Third World backwater where one of the precious few positive aspects of daily life is that FAA rules are at least for now a mere twinkle in the eye of legislators. As such I routinely fly 6-mile round-trip Litchi waypoint missions that extend far beyond visual range and RC signal reach. I have neither the desire nor the need to utilize DJI Go products because they are in my opinion markedly inferior to Litchi when it comes to waypoint mission planning.

To now find myself FORCED by a DJI firmware update to choose between flying my drone at the mercy of DJI Go with its expanding list of restrictions, or grounding my drone indefinitely, is thus a truly distasteful predicament in which to find myself, bearing in mind how much I shelled out to purchase my Mavic drones that I’d hoped would be my final drone purchases.

Ranting aside, I haven’t thrown in the towel yet, and will continue my efforts toward successfully rolling back the firmware in both my Mavic RC controllers so as to attain parity with the firmware edition in the drones that I selected in this quest to regain access to my beloved Litchi.

To my utter astonishment, a completely FREE drone hack software package called DUMLdoreV3 enabled me to finally roll back the firmware updates on the controllers of both my Mavic drones, in a matter of seconds. I can now discard my previous assumption that free stuff is bound to be of substandard quality. Nothing could be further from the truth in this particular instance.

Refusing to believe that such a quick process carried out by a free hack utility could actually solve a problem that confounded me for 3 long days, I hurriedly tested both drones with Litchi and then watched as that elusive camera view materialized on my iPad screen, right after the drone controller indicated a successful connection for both drones in turn.

Before stumbling on this free drone hack utility called DUMLdore V3, I lavished 40 euros EACH on licenses from No Limit Drones, and Drone Hacks.com, along with a further $50 to purchase a Winzip license without which I couldn’t access the No Limit Drones files.

That total of about $150 expenditure was not wasted, however, because it took Drone Hacks.com’s sister website called DankDroneDownloads, for me to obtain and save a discreet copy of the early DJI firmware binary file that was later utilized by DUMLdore V3 to instantaneously roll back the firmware on both Mavic controllers one after the other.

And so there you have it, fellow Litchi Meisters. My inept, haphazard, bumbling hit-and-miss approach to problem-solving actually worked in the end against all odds, and now, with all planetary orbital trajectories restored to their rightful status, I can declare with full authority that all is once again well in the known universe at this time.

In conclusion, my considered observation is as follows, folks: Yeeeeeeeehaw !

Ahem. Thank you and God bless Armenia!