Android 13 Pixel 5a v4.25.0-g black video screen from air 2s camera

I have tried rebooting the phone. There is not another DJI app running. It does prompt be which app with controller is turned on - I select Litchi - and all seems well except the blank video from the aircraft. Any one have suggestions, I just bought it and am hoping to avoid uninstall/refund. Thanks!

I think it’s best to contact Litchi directly:

There used to be a live video feed problem with the Pixel 6 series due to a bug in the DJI SDK, it was fixed in version 4.22.0.

Thanks TriBar. I have emailed them.

Update…Litchi has been trying to help:

Litchi: We do not have this device, did you follow connections steps in our online guide at

Me: Yes, I did follow the online guide;

  • Make sure another app is not running in the background (i tried both force close DJI Fly and reboot)
  • The DJI Fly app, which does show the video feed, is not defaulted to ALWAYS launch each time. I always get the question, which app, DJI Fly or Litch, and am choosing Litchi ‘only this time’.
  • After both DJI Air 2S and controller have been turned on for a bit, I plug in the usb cable and get the prompt above.

I thought it was related to my Pixel 5a, and I wanted a larger screen, so I purchased a Galaxy Tab S7 FE 2021 Android tablet (because someone mentioned in the fornum mentioned they used that). I was very disappointed to when the exact same issue happened. No video feed.

I then thought perhaps the insurance I bought from DJI, which was bound to the aircraft, could be causing the issue so I un-bound that and tried again but with the same results.

The aircraft and controller (the one that comes with the Air 2S fly more combo) both have been updated to the latest firmware.

Are there any other suggestions or additional information I could provide that would help resolve the issue?

Litchi: Have you tried with another usb cable? Maybe yours is faulty.

Me: My existing cable works with DJI Fly but I tried another cable anyway and I’m still not seeing the camera feed from the DJI Air 2 S. I also tried the ‘Reset all settings’ which restarted the app and that didn’t work either.

I’m open to trying new things if you’ll point me in the right direction.

I share all this in case anyone else has any ideas. Thanks in advance. I’m in the U.S., but I’m sure someone else has the Litchi app working in the U.S. with a Air 2 S and a Galaxy Tab S7 FE?