Mavic Pro Stops and Hovers Uncommanded During Litchi Waypoint Mission

On the return leg of an otherwise uneventful 7-mile Litchi waypoint mission my Mavic Pro was about a mile away from the launch point when it hit the brakes, paused, then resumed forward motion about half a dozen times before it came to a complete stop with the battery at 30%. Pitching the nose down with a fully forward right stick made no difference, and the drone remained stationary for long enough to become truly worrisome.

Suspecting strong winds aloft that weren’t apparent at ground level, I dropped the altitude from the RTH setting of 200 feet AGL, down to 160 feet, but the Mavic retained that stationary hover. With panic starting to set in, I then gunned the throttle and sent the drone up to 450 feet, before switching to sport mode and applying a full right stick forward to get the nose down and break that stalemate.

Finally, the drone began to move toward home, slowly at first, and then at a respectable clip of 40 mph, BUT while it was speeding towards me, the camera gimbal went wild as it has in the past a couple of times, with the recording toggling on and off numerous times until finally, the drone made an appearance at 450 feet AGL and 20% battery.

Obstacle avoidance had been left active for my flights thus far, but now that I’ve read several Litchi users’ warnings to be sure and disable all obstacle avoidance cameras when flying Litchi missions, I will ensure they are turned off from here on out. I’ll run another flight test with obstacle avoidance turned off along the same route if the weather is fine tomorrow morning, and write back here with my findings.

I must ask though whether any Litchi users that own Mavic Pro1 drones have encountered such random stops during waypoint missions, and whether simply disabling obstacle avoidance pre-flight resolved the issue on subsequent missions. I’ve actually seen this behavior once in the past, but in that case, lowering the altitude to just above treetop level released that parking brake and allowed the drone to resume the waypoint mission, leading me to presume wind was the culprit on that occasion.

Any thoughts on this subject that can be shared would really be appreciated. Today’s flight was a nail-biter for sure, and I am anxious to learn how to go about preventing any recurrences of such uncommanded stops during future waypoint missions.

Could be that the Mavic was looking into the sun.
It regards the bright sun light as an obstacle, and stops.
Turn off all obstacle avoidances and you will not have this problem.
Watch this >>

.

2 Likes

Today’s flight was right at dusk with the sun low in the sky, but it ran north-south which I thought might rule out the sun being mistaken for an obstacle, so I was at first ready to ascribe that stop-and-go behavior to shifting winds. Regardless, from now on I’ll ensure that obstacle avoidance is disabled before each Litchi waypoint flight I launch, at least to minimize the odds that such an anomaly strikes again.

Looking at this video clip, I see the same sort of random hesitance that took place with my Mavic Pro today. A possible factor mentioned in another forum was that if DJI Go4 is not properly shut during a Litchi flight, DJI could send unwanted signals to the drone, especially if airplane mode is not selected on the iPad. I did briefly open DJI Go to check RTH altitudes, and truth be told, I’ve never been sure how exactly to disable DGI Go beyond merely closing its window and reopening Litchi.

At the 8.33 minute mark of this video clip, I can see the break dancing gimbal effect that I also witnessed with my Mavic Pro today.

Come to think of it, I really have no need for obstacle avoidance given that all my flights are between 150 feet and 200 feet AGL, which in my relatively flat landscape here, is well above all obstacles. Sometimes less is indeed more. My trusty old Phantom 3 Standard has never displayed any odd behavior during Litchi missions, perhaps because it has no obstacle avoidance incorporated into its minimalist design.

I never have obs. avoidance turned on, as I plan my missions carefully. I don’t even use it when flying manually, as it slows top speed down.
My Mavic Pro is now 6yrs old and still flies perfectly. It’s a dream machine! Still on original batteries too!

1 Like

I have, several times on the same mission (flown once every week during ‘golden hour’ for a whole year).
Took me a while to figure it out. Disabling object avoidance fixed it.

1 Like

I’ll be doing the same and disabling obstacle avoidance henceforth. I suppose for drone fliers who operate their drones at low altitudes and around obstacles, having the sonar turned on is good insurance, but since my drone flights are all well above the treeline between 150 feet and 240 feet AGL, obstacle avoidance is a completely unnecessary feature that could result in the loss of a drone during a Litchi mission, on account of those random mid-flight stops it causes.

The only disadvantage I’ve seen to having obstacle avoidance off is that the drone flails around a bit on landing approaches, and I have to be very careful with the throttle inputs to avoid a hard landing. I resorted to reactivating obstacle avoidance each time the drone returned from a Litchi mission, but a few times there simply wasn’t time to do that, as the battery was running low and I needed to land quickly.