Managing software on my Mavic Air without DJI apps

Hi all. I have a Mavic Air (the original one). I haven’t really used it much at all over the last couple of years. But I now have more time on my hands and want to start using it again. However, I can’t now install DJI G0 4 on my phone and their forum help responses seem to indicate this is a common issue with Android 12 and above. There is no indication of when they will address this.

Litchi runs fine thankfully. My issue is that if I can’t get Go 4 to work, I can’t check the software on the drone, nor I guess get up-to-date flight restriction data. I don’t want to inadvertently fly in a restricted zone or with software with known bugs/problems!

Can I update the software and such via Litchi? If not, is there any other 3rd party app for Android that would allow me to do this?

Any help is greatly appreciated. I can’t afford to buy a new phone, just so I can install the app - that just seems silly.


Cant you use DJI Assistant on the computer to update the firmware?
I’m running Android 13 on a Samsung S22 Ultra with no problems using DJI Go 4

I’ll try that - thanks for the idea, you never know :slight_smile: Does that work on a mac, or just Windows?

As for DJI Go 4, I tried to run it, it appeared to load, but I just couldn’t actually get it to run (seems a lot of people have had this issue from web searches).

I tried downloading the apk from the DJI site: DJI GO 4 - Download Center - DJI. It made no difference.

I totally uninstalled the app, then tried to install it from fresh (after restarting my phone) - now it will not install. I go through the install steps and it ends up with “App Not Installed”. I’ve even tried multiple apk installers, all with the same result.

I’ve got an S10+ and have also tried on my Samsung A8 tablet and neither work :frowning:

It would appear that I can’t get that for my Macbook: -

DJI Assistant 2 For Mavic

Compatible with Mavic.DJI Assistant 2 is not currently compatible with macOS version 11 or later. This issue will be resolved in a future update.

I ha actually already installed Assistant 2 (I forgot about that). It won’t let me connect to my Mavic Air.

However, I persevered and look to have a solution. I found an older version of Assistant 2 on the DJI site (2018, rather than the current 2020 version). I uninstalled the newr version and installed the older version. I can at last connect to my Mavic Air and it appears to be updating the firmware :slight_smile:

1 Like