I need to know how to get up and running on Litchi from scratch

I have given up on using any DJI software because I had to change phones and mine happens to be incompatible. However, after purchasing Litchi, it seems that I need those apps to get started on Litchi (getting the latest firmware, “registering” Litchi with DJI servers, etc.) So I’m stuck and brand new to Litchi. I appreciate any help. Right now, when I turn my phone on, turn the remote on, connect the phone to the remote, and then turn the drone on, I still get a message at the top of the page that says “Disconnected.” My drone is a Mavic Air 2.

There is no such thing.

You should start here:

Read the section titled: “Connecting Litchi to your drone”

I was using the wrong terminology. I should have said “verifying,” not “registering.” Anyway, the error message I am getting is, “Cannot connect to DJI servers to verify the app. The server may be busy or is not reachable.” But everything I’ve read as a solution does not apply. I do not have either DJI Fly or DJI Go 4 on my phone, and I have 11 G of RAM free. I have tried opening the app both with and without Wifi calling, and I have no other issues using the internet. Other ideas?

Before you can fly a DJI drones for the very first time, you have to activate it, and this has to be done using a DJI app, which for the later drones would be DJI fly, and there is no way round this

I have actually flown the drone several times, but none with my new phone, a Moto G Pure, which is “incompatible” with any of the DJI apps. So I purchased Litchi (which downloaded and initiates just fine) but it sounds like I can’t even use this 3rd party app because of the same DJI limitations. This is so frustrating because I am on Consumer Cellular which offers 32 Android phones, only one of which is listed as “compatible” with my drone (and it’s an $1,100 phone – I already spent almost $1,000 on the Mavic Air 2 and package). So it sounds like I have the choices of buying a super-expensive phone, changing phone companies, or selling my DJI drone and never buying another one (the most likely one). Sorry, frustrated. Any other suggestions before I make such a painful choice? Thanks for all the responses so far. Much appreciated.

Pick up a second hand phone that is compatiblr

Thanks. I will look around. Might be a good workaround. Thanks for the suggestion.

Your phone needs to have a WiFi internet connection in order to verify the Litchi app to the DJI servers.

A cellular internet connection does not work for this process.

Also a public WiFi internet connection, lets say from your local grocery store or a police station, does not work.

Furthermore you may need the official DJI app some time for:

-Activating a new drone.
-Firmare updates.
-Unlocking No-Fly-Zones
-Calibrating (if needed) the IMU.
-(Re)Naming the drone.
-Some MC settings.
-Some obstacle avoidance settings.
-Gain & Expo tuning.
-Read the Sensors State.
-Image transmission settings.
-Aircraft battery settings.
-Payload setting.
-Beginner Mode.
-Some Remote controller settings:
-Stick Mode
-5D button customization.
-Remote controller calibration.
-Remote controller pairing.
-…

So if needed borrowing or buying a DJI app compatible (second hand) phone/tablet may become mandatory.

What nonsense.

I always use only mobile Internet, it takes no more than 30 seconds. Reinstalled litchi yesterday.

It is not true. Litchi always downloads the database from the dji servers the first time it is turned on after installation.

What version of android do you have?

What database is Litchi downloading from the DJI servers?

Ask litchi about it.

“Downloading DJI Database…” 0…100%

Your message suggests you know something about this so I’m asking you. What database?

I report that litchi displays an inscription in the center of the screen when it is first launched. And it will not start if, for example, turn off the Internet

“Downloading DJI Database 0%”

You can also uninstall litchi and install it again to check it out.

I was told by litchi that they do not download any data, the application simply registers with the dji sdk the first time it is launched.

But for some reason the inscription in the application is called download database

I have Android 11. Just an update; I got Litchi up and running two evenings ago. However, it went back to not connecting last night. I’m now using my old phone to try and get things going with both Litchi and DJI Fly. DJI Fly will not even run now on my old phone, saying, “RC is not connected to the mobile device.”

Are you using version 4.25.0?

My version reports as being 4.19.127+. When I try to update, it reports the current software version as RRHS31.Q3-46-110-10 Security patch: July 1,2022, and says “You’re using the latest software.”