Curve at end of Waypoint problem Mini 2

I know I must be missing some setting but I can’t see what I’m missing. I’m attaching some screen shots. When looking at the mission in VLM I get this issue.

As the drone moves from WP1 to WP2 it points straight towards WP2 like I want but about 100’ before it gets to WP2 the drone rotates to point at WP3. I want it to to straight to WP2, once there rotate towards WP3, go to WP3, then rotate towards WP4, etc. This same “curve” happens as the drone approaches WP4, etc.



I think your problem is the interpolate option with Gimbal Box. Switch to Disabled

1 Like

Changing the Gimbal Box to Disabled did not fix it. It appears that it is looking 2 waypoints ahead instead of the next waypoint for where the camera points.

I assume you work with the android app.

According to the manual (which is very extensive) I foud this:

Mission Settings

  • Heading Mode: Defines the heading of the aircraft during the mission. Choose between “Toward next Waypoint” (“Auto” on iOS) where the aircraft will point toward the next waypoint, “Initial Direction” (“Initial” on iOS) where the aircraft will keep the heading it has when the mission is started, “User Controlled” (“Manual” on iOS) where you are able to control the heading of the aircraft during the mission using the left joystick left/right (mode 2) or “Waypoint Defined” (“Custom” on iOS) where the aircraft will use the heading defined at each waypoint. Using “Waypoint Defined” (“Custom” on iOS) also means that the aircraft will smoothly transition from one waypoint’s heading to the next.

Maybe try it out with a simple rectangle…

I’m using the Mission Hub on-line to create the mission, then running the mission in VLM to confirm the mission before it is run. I have read those instructions. Here is a link to a simple square mission that is showing the same behavior. Mission Hub - Litchi

Hi, I copied your mission to my area and flew it with the simulator with my mini. It flies as it should and the drone turns exactly at the waypoints.

Here is a screen recording of what it looks like to me.

I flew it wit th sim mode from litchi. This looks to me a Google earth problem, rather than litchi.

switch off interpolate on gimbal pitch in settings and on the individueal waypoints in the mission.

1 Like